Local Payment Incident for Payouts in Mexico

Incident Report for localpayment

Resolved

This incident has been resolved.
Posted Apr 30, 2026 - 17:22 UTC

Update

The issue affecting payouts in Mexico has been resolved.

Transactions processed during the incident window may experience longer-than-expected completion times and are being reviewed by our team.

We will continue to keep you informed.
If you have any questions or need assistance please contact our support team at support@localpayment.com

Kind Regards,
Localpayment.
Posted Apr 30, 2026 - 03:16 UTC

Monitoring

We would like to inform that corrective actions have been successfully applied, and we are already observing improvements in our payment processing metrics.
Our team continues to closely monitor the platform to ensure full stability before marking the incident as resolved.
We will provide further updates if any new developments occur.

Kindly Regards,
LocalPayment.
Posted Apr 30, 2026 - 00:05 UTC

Update

We continue working on the fix for the issue affecting payouts in Mexico. Remediation is ongoing and we are monitoring the situation closely.

Further updates will be shared as more information becomes available.
If you have any questions or need assistance please contact our support team at support@localpayment.com

Kind Regards,
Localpayment.
Posted Apr 29, 2026 - 23:44 UTC

Identified

Our engineering team has identified the cause of the errors affecting our payouts platforms.
We are currently implementing corrective measures to restore normal operation as quickly as possible.
Further updates will be shared as soon as additional information becomes available.
If you have any questions or need assistance please contact our support team at support@localpayment.com

Kind Regards,
Localpayment.
Posted Apr 29, 2026 - 19:15 UTC
This incident affected: Mexico (PayOut Mexico).